1

Topic: FilaWinder Documentation

STLs can be found at the bottom of this post.

Assembly Manual-

https://dl.dropboxusercontent.com/s/u6l … 1400126234

Assembly Videos-

http://www.youtube.com/watch?v=Cdzc6wZ_qTE

http://www.youtube.com/watch?v=bXzrUiHrQAg

http://www.youtube.com/watch?v=FvaWGfeOzWw

Setup and Operation-

https://dl.dropboxusercontent.com/s/45u … v5Zgyiwrlw

http://www.youtube.com/watch?v=uWDkBzS0 … e=youtu.be


Current Firmware- The winder comes programmed, but you can use these files if you want to make changes.

FilaWinder_v11  Is the current default firmware.  Use a jumper to enter 3mm mode, and use a jumper to turn troubleshooting mode on.

https://www.dropbox.com/s/1mg6rnx1rhndo … 1.zip?dl=0


3mm Mode-

Place a jumper on the pair of pins at D12 to set the guide movement to 3mm.

https://dl.dropboxusercontent.com/sc/8xis175ddennxwa/Xu27JvF2wx/0?dl=1&token_hash=AAGbRDw9NifgOBwRj1zjM8Hg4dBjrtUQwW8wzDVu-L52TQ


Troubleshooting Mode-

Place a jumper on the pair of pins at D11 (next to the jumper shown in the picture above) to enter troubleshooting mode.

Go in the Arduino software to Tools / Serial Monitor to get a display of the status of the buttons and other functions.  You can continue to run the winder in troubleshooting mode, but be aware that the sensor responds a little slower.  If the filament gets jerked away from the sensor suddenly, it may not notice and keep the motor running.

https://dl.dropboxusercontent.com/s/04tc43s6q9p70p0/Troubleshoot.JPG?dl=1&token_hash=AAG84Yfbh5ESQOEc8zjRjgHczrvHluBRkArZ2j65V5CJVw

Post's attachments

FilaWinder STLs.zip 743.24 kb, 488 downloads since 2014-11-16 

You don't have the permssions to download the attachments of this post.

2

Re: FilaWinder Documentation

There appears to be an issue with the assembly documentation.  The last page is a repeat of a prior page, and there isn't anything in the .pdf that shows what you hook the winder motor to.

3

Re: FilaWinder Documentation

I managed to leave it out of both the video and the written instructions.  The short answer is plug it into the top left pair of headers labeled Motor.  The direction the motor turns will depend on which wire is on the + side, so if the spool turns clockwise, flip the plug over so it turns counterclockwise so it pulls the filament over the top of the spool.

4

Re: FilaWinder Documentation

Ok, I received my FilaWinder and started assembling it. However, something seriously doesn't make any sense. While following along with the video instructions (still on the first one), and immediately after  installing the support base and support bar, I noticed that the 'U' shaped end of the support bar doesn't line up at all with the threaded rod. Not even close! The installation so far is idiot proof so I can't see how I could have possibly made a mistake. See pictures.

https://dl.dropboxusercontent.com/u/60513393/IMG_20140111_091317.jpg
https://dl.dropboxusercontent.com/u/60513393/IMG_20140111_091326.jpg
https://dl.dropboxusercontent.com/u/60513393/IMG_20140111_091347.jpg
https://dl.dropboxusercontent.com/u/60513393/IMG_20140111_091355.jpg

5

Re: FilaWinder Documentation

The problem is the STL.  Last time I revised the support, my motor mount board had a backward lean to it, making the rod higher than it should have been when I measured it.

Here is a revised support bar-

Post's attachments

Support Bar.stl 89.54 kb, 113 downloads since 2014-01-11 

You don't have the permssions to download the attachments of this post.

6 (edited by malek1979m 2014-01-11 18:41:01)

Re: FilaWinder Documentation

You're welcome.

Ok, there's another issue. In the package there was a piece of 6mm PTFE that looks to be around 10" in length and a piece of 4mm PTFE that looks to be around 24". Since I'm extruding 3mm filament, what am I supposed to do with only 10" of PTFE? First of all the instructions say to cut it down to 12-14", but obviously it's not long enough. But that's the small issue. The bigger is this: The instructions say to cut the remaining 4mm PTFE into equal pieces and to place them in the 4 holes where the laser sensor is. And the holes obviously will ONLY fit 4mm PTFE, so what good will that do me if I'm extruding 3mm filament?

EDIT: Oh I see... the filament isn't actually going THROUGH the PTFE, but between them...

7

Re: FilaWinder Documentation

The ends of the 6mm tube would be mostly flush with the holes on the board to start.  3mm filament will be looser in a 4mm ID tube than 1.75mm filament in a 2mm ID tube, so the loop for 3mm filament wouldn't need to be as wide.   If the filament isn't pulling tight enough to the spool, make the loop tighter.  If it seems too tight all of the time, I can send you a longer section.

8

Re: FilaWinder Documentation

Ok, I got it extruding and winding pretty smoothly to within +-0.05 accuracy. However, I've been having some difficulty with the servo motor and the filament guide thing attached to it. Now... I realize the machine is intended to work with both 1.75mm and 3mm filament. However, is it possible that the way the servo motor behaves is programmed to work with 1.75mm only? The manner in which it goes back and forth (very slowly) suggests this. But when someone is using 3mm filament, would it not need to take bigger steps? My filament is getting bunched up on the edges of the spool as the filament is always beating the filament guide.

9

Re: FilaWinder Documentation

I need to make a version of the firmware that will have filament diameter selectable by a jumper, but meanwhile here is one that will move it based on 3mm diameter.  An alternative is adding another magnet to the gear to trip the guide twice as often.  You can also try setting the guide limits short of the edges of the spool so the guide begins to pull the filament back toward the center sooner.

Uploading the firmware:

If you don't already have it, download and install Arduino from http://arduino.cc/en/main/software

Add the QTR and PID libraries by going to Sketch>Import Library>Add Library and select the QTR and PID zip files. 

Open FilaWinder_v6_3mm.ino and plug in to the USB on the board.

Under Tools>Board select Arduino Nano

Under Tools>Port select the port that Arduino has appeared on.

Click the upload button (the sideways arrow).

Post's attachments

FilaWinder3mm.zip 25.82 kb, 59 downloads since 2014-01-13 

You don't have the permssions to download the attachments of this post.

10

Re: FilaWinder Documentation

I've actually been having some difficulty since the 3mm firmware upgrade. The initial test seemed ok, but now that I'm about ready to start using it to wind filament I noticed that manual mode isn't working at all. I can't adjust the speed of the winder when on manual mode. And it took me forever to configure the limits of the servo motor. What happens is this: I turn on auto mode, then I turn on power, and the first thing that happens is the servo motor moves the filament guide all the way to the far left and stays there, regardless of what position I have the potentiometer. Holding the left or right buttons while turning the knob does nothing. It decided to work once, and only once, and I had the opportunity to set the limits during that time as well as the initial movement position/direction. Not sure what's going on...

11

Re: FilaWinder Documentation

The potentiometer might have quit working.  Do you have a multimeter?  Check the resistance between the middle pin and one of the outside pins and make sure it changes as you turn the knob.  If it doesn't, I'll send you a new one.

12

Re: FilaWinder Documentation

Maybe worth posting both firmwares in the OP?

13

Re: FilaWinder Documentation

elmoret wrote:

Maybe worth posting both firmwares in the OP?

Good idea.  I was watching the videos and reading the documentation and until I read the posts above this one I hadn't realised that 3mm needed different firmware.

Masterbatch, ABS and PLA Pellets available for UK and Europe.
http://www.emakershop.com/Seller=1324

14 (edited by malek1979m 2014-01-25 01:07:35)

Re: FilaWinder Documentation

IanJohnson wrote:

The potentiometer might have quit working.  Do you have a multimeter?  Check the resistance between the middle pin and one of the outside pins and make sure it changes as you turn the knob.  If it doesn't, I'll send you a new one.

The potentiometer seems to be working ok, according to my multimeter. Reading ranges from 0 to 19,000. Yet the servo motor doesn't seem to be responding to the knob. When it does (which is 2% of the time), it just jitters for a bit and stops. All the connections seem fine on the pot and on the arduino... It's weird because it was working fine.

EDIT: Interesting... I replaced the 20k pot with one of my 10k pots and it seems to be working fine, even though the old one did seem to be working according to my multimeter. You don't have to send me a new one. I've got loads of them sitting around, unless you don't think using a 10k is a good idea. Seems to deliver the same results though. The next step up I have is a 100K pot.

15

Re: FilaWinder Documentation

Apparently changing the guide movement from 1.17 degrees to 2 degrees makes everything not work.  Changing it to 2.00 degrees does work.  So on lines 248 and 252 change that 2 to 2.00 and see if that fixes everything.  Seems a little picky to me.

16

Re: FilaWinder Documentation

Well, I'm doing another spool now. We'll see how this one comes out before I make any changes. If it acts up, I'll make the proposed changes.
Question: So what formula do you use to come up with 2 degrees? Or is it trial and error? It seems like a 2 degree rotation translates into more than 3mm horizontal movement, as the filament guide seems to be moving slightly too fast, leaving gaps between filament on the spool. Also, will that number not depend on the actual filament thickness? If I have 2.75mm filament for example, what number of degrees would I need the servo motor to turn? What is the formula, if there is one?

17 (edited by malek1979m 2014-02-04 12:47:24)

Re: FilaWinder Documentation

Ok, so here's the deal... on a different note... The FilaWinder, as it is without any modification, will NOT work with 3mm filament. At least not the servo motor/filament guide functionality, as I've mentioned in the past. Because of the stiffness of the 3mm, The servo motor is not able to move the filament guide far enough to the right of the spool as 3mm filament does not have enough flex in it. So here's what I've done. I've extended the bottom base by several inches (I printed the piece), so the distance between the filament guide and the PTFE tube has been increased by 5.5". This puts a lot less stress on the servo motor, making it a lot easier to move the filament guide all the way to the left and right of the spool. I've tested it and it seems to be working. I'll post the part on Thingiverse soon.

EDIT: Here it is: http://www.thingiverse.com/thing:233877

https://dl.dropboxusercontent.com/u/60513393/IMG_20140124_212645.jpg

https://dl.dropboxusercontent.com/u/60513393/IMG_20140124_212636.jpg

18

Re: FilaWinder Documentation

I had it read out the guide position in degrees from one end to the other of a 85mm wide spool and worked out the relationship between mm and degrees.  It isn't exactly linear since the further it gets from center the more rotation it takes to move 1 mm.  However it doesn't need to be exact.  The filament guides itself to a point until the pull back toward the center gets strong enough to overpower the tendency of one coil to snap down next to another.  At that point the guide is there to keep pushing it the rest of the way to the edge.  Then it backs off and lets the filament move back toward center. 

You can try reducing that angle to slow it down a bit.  It really just takes some trial and error, the speed will depend on the actual width of the filament, and the relative position of the center of the spool to the hub of the servo.  It won't make perfectly stacked rows of coils, but it should be reasonably neat.

19

Re: FilaWinder Documentation

I'm having some trouble of a different nature.  I've finished my build and I'm testing everything to make sure it's working as expected before running some filament.  I'm using the standard, vertical configuration with 1.75 mm filament.  My problem is that the servo that guides the filament does not oscillate as expected.

I switch the left switch up to automatic mode and turn it on.  I can use the left button with the pot to set the left limit, the right button to set the right limit, and the center button to set the start position.  This all works as expected.  Turn the pot all the way left, switch to manual, make sure the magnet is away from the hall sensor, press the center button to calibrate, and run some filament between the laser and sensor for a few seconds.  When I switch the left switch back to auto, the motor works as expected: with filament between the laser and sensor the motor turns, as the filament rises out of the sensor range the motor slows and then stops.  But while the filament is in range and the motor is moving, the servo is not moving the filament guide.  It will jiggle just a little bit as the magnet moves past the hall sensor, but it's not moving.

Thoughts?

20

Re: FilaWinder Documentation

The most likely thing is that the magnet is the wrong way around.  Take it out of the gear and wave it back and forth over the sensor about 1/4" away, then flip it over and try again and see if the servo moves.

The other possibility is that the buttons are plugged into the wrong headers so the minimum servo angle is set higher than the maximum servo angle.  If turning over the magnet doesn't work, try switching the left and right buttons at the control board.

21

Re: FilaWinder Documentation

Thanks Ian for the swift reply!  You and Tim rock when it comes to support.  smile

Coloradans usually know which way north is, and I paid very close attention to this when I put the magnet in, because I knew it was never coming out again without destroying the spool gear.  (I had to tap it in with a mallet.)  So I was really hoping this wasn't what I had screwed up!

Short answer: the spool gear wasn't close enough to the hall sensor for it to register and move.  The reason?  Well, my 3D printer is pretty good, but not great.  The drive gear didn't slide onto the motor shaft very well, and I had to file it down a bit to get it to fit.  The drive gear wasn't far enough down the motor shaft, so the spool gear was further away from the hall sensor as a result, and it wasn't registering as the magnet moved by the sensor.  Fixing the drive gear so it fit better on the motor shaft, and thus moving the spool gear closer to the hall sensor, fixed the problem.  Hopefully this info will help someone else facing the same issue.

With that, I'm ready to start spooling!  :-D

22

Re: FilaWinder Documentation

Of all the 3D printer-related DIY kits I've built, the FilaWinder has been the most straightforward and bumble-proof kit yet.  Really solid design, works exactly as intended (when you do it correctly!), and I couldn't be happier.  Great job Ian!

In other words, I'm now spooling filament.  smile

23

Re: FilaWinder Documentation

d'Armond wrote:

Of all the 3D printer-related DIY kits I've built, the FilaWinder has been the most straightforward and bumble-proof kit yet.  Really solid design, works exactly as intended (when you do it correctly!), and I couldn't be happier.  Great job Ian!

In other words, I'm now spooling filament.  smile

Ian's showing me up. Gotta step my game up now.

24

Re: FilaWinder Documentation

Hey, the Filastruder was also very well done, and it operates trouble-free.  It just took me longer and was more susceptible to my goofs.  But they're both excellent.  The third kit that I've built, the 3D printer, is a constant struggle to keep working, and when it is working, it's still only so-so.  The hardest part of the FilaWinder was 3D printing the pieces (in particular, the gears) for assembly.  They took a lot of post-processing. 

There were two things that I found harder about the FilaStruder: the instructions didn't include a parts list that was easy to compare to what came with the package.  This made it hard to follow the instructions when, for instance, it says to take a "nipple" or a "coupler" and do something with it.  The second challenge was with the wiring, which took me a while to work out, and I ended up following someone else's instructions that were posted to these forums. 

So, to bring this post back to the OP, there was only one thing I found missing in the FilaWinder instructions: where the laser sensor plugs into the board.  There are two sets of pins that it could be, and I was nervous about trying the wrong one and messing something up.  But of course it worked out, so I wouldn't say it's a big deal.

25

Re: FilaWinder Documentation

Just finished my filawinder.  I think
It's working but I am trying to wave a piece
Of filament between the sensor,  but the
Motor keeps running..   Do you have a suggestion
On how to test that the sensors are working?
I didn't see any response during the sensor
Cal so I don't know what to expect.  I did check
The auto/manual signal on the board in case it was the
Problem.