1 (edited by kaldonis 2013-06-25 15:14:00)

Topic: Extreme shift after a few layers

We've had our SD3 for a few months now and while I wouldn't say it is perfectly calibrated, we have been producing some decent quality stuff. Today I experienced something very bizarre... after a few layers (not sure how many, lets say 8 or so), the printer seems to have shifted about 1cm towards the back of the printer. I've read about layer shifting and the stairstep effect, but I'm pretty sure this has to be something else.

I've attached a photo of the print. You can tell that the top few layers are offset about 1cm from the bottom layers.

It may have been a fluke as I haven't tried reprinting it yet (and won't get a chance until later this week) and this is the first time we've seen it, but I thought I'd check here first to see if anyone has seen anything like this before or has an idea what could have caused it? I'm fairly certain the STL is OK, it looks fine in the preview and I ran it through netfabb first...

Edit: I should point out that this print has two separate (different) pieces, I had a couple of people assume that the "extreme shift" I was talking about was the second piece itself...

Post's attachments

shift.jpg 178.94 kb, 1 downloads since 2013-06-25 

You don't have the permssions to download the attachments of this post.

2

Re: Extreme shift after a few layers

A big layer shift (y axis)  happened to me the other day on an sd3 with no fan running on the circuit board.  The temp and humidity had jumped from 65f to 85f.  I took the printer down to my cool dry basement and it went through a two hr print fine.

Matt

3

Re: Extreme shift after a few layers

my y shifts are usually caused by filament, the friction of pulling the filament made y stepper to skip couple steps.

Solidoodle2 with Ceramic tile heated bed http://www.soliforum.com/topic/2544/my- … eated-bed/
"1kg should last for an while" is a lie!

4

Re: Extreme shift after a few layers

could be your powersupply. the laptop bricks SDs ship with are pretty "flimsy". i already upgraded mine to one of these:

http://www.amazon.com/Universal-Regulat … wer+supply

with a 12 amp fuse between the supply and my printer. no more annoying capacitor chirp for me!

also consider a UPS, you can get a cheap one for $80 to $100 and it really helps take all the guess work out of power issues since you can rule out any glitches coming from the mains power. not to mention my printer continues happily printing along when a summer thunderstorm makes the lights flicker.

5

Re: Extreme shift after a few layers

In my experience, shifts like these are almost always caused by an overheated controller, specifically the pololu driver.

Put at least a 40mm fan on the controller. Problem solved.

If I forget to turn my fan on I get the dreaded skip in a matter of minutes.

6

Re: Extreme shift after a few layers

This is so weird.  I tried to print a model this morning and this evening, and I had the same thing, The first shift occurred in the "Y" axis, and it was about and inch (25cm) forward.  It's a fairly large and complicated print, and the shift happened about 3 layers into the print.

I killed the print and this evening I tried again.  The shift happened twice, once in the X and Y axis (diagonal shift), the finally on the Y axis again, twice in sequence.  Once about a 1/2" shift, then another 1/4".  This last time I could hear a little pop as the shift happened, so I'm not sure where it came from.

I did not have this problem before, but here are a the variables that I can think of:

1.  A few days ago, I did the mechanical "fix" Solidoodle support came up with for fixing round circles.  I did it exactly as they show it on the video, and made sure that all the belts are properly tensioned and the set screws secure.  So I'm pretty sure nothing is slipping.  I can manually move the carriage back and forth and it's smooth and I can't feel any slippage or skipping.

2.  The other possibility is the weather here.  It's been in the 80°s even in the evening and heat might be a contributing factor, but I think that's reaching, it's been hot before and I didn't have any problems like this.

3.  Last but not least, I made one modification to the system, I added a 12V extruder fan, which seems to work OK, and is being driven from the 12V header on the mainboard.

So anyone have any ideas as to what we're experiencing?

Go out there and make something.
SD3 printer w/too many mods.  Printrbot Simple Maker Ed.

7

Re: Extreme shift after a few layers

pirvan wrote:

So anyone have any ideas as to what we're experiencing?

I think it's most definitely a stepper driver issue. I would:

1) check the voltage of the trimpots
2) cool the electronics

I had exactly the same problem when attaching the pengpod, it turned out it was a conflict between USB and regulator voltages. If the two steps above don't work, I suggest cutting the 5V line from USB on the sanguinololu board.

Sorry that we all gave you slightly different advice, but we actually mostly agree that it's a driver problem, we just have different approaches to it smile

8

Re: Extreme shift after a few layers

Yeah it's definitely the stepper drivers. If you touch them you will burn your finger (that's a bad sign) and unfortunately they aren't shipped with heatsinks mounted when they should be standard. Some thermal adhesive, small heatsinks from amazon and I even added a fan for air flow and problem solved. Goodluck!

9

Re: Extreme shift after a few layers

westin.williams wrote:

Some thermal adhesive, small heatsinks from amazon and I even added a fan for air flow and problem solved. Goodluck!

Hi,
If you have any links to what you used, I'll bet that would be appreciated by some ...
Matt

10

Re: Extreme shift after a few layers

Well,  That's what I love about the community, you ask questions and you get help.

You guys were right about the overheating stepper drivers.  I put a fan in front of the bpard, and was able to print the entire job without any problems.  Prior to adding the fan,  I ran one more test run and it failed on layer 5 even though the system had been off all day.

So now I'll have to make a fan holder and air duct.  Or buy a 1U blower and mount it right next to the board.

Go out there and make something.
SD3 printer w/too many mods.  Printrbot Simple Maker Ed.